Error 404 after planned maintenance

Major incident Europe North Europe West Europe Germany West Central
01-19-2024 08:24 CET · 2 hours, 11 minutes

Updates

Post-mortem

Dear valued Jedox customers,

On Friday 19.01.2024 between 02:00 AM UTC and 08:52 AM UTC Jedox services were not accessible for a number of customers from the following 3 cloud regions:

  • North Europe
  • West Europe
  • Germany West Central

All affected users could have seen the 404 – not found page error, which was shown at their login pages.

The root cause of this issue has been identified as being a modification in the backup script, which it was overwritten by a patch applied to improve the scalability and stability of our cloud infrastructure.

Although we are doing extensive QA, risk assessment and reviews of the patches and changes before their rollouts to the customers’ infrastructure, there could be rare situations when all implications are not always foreseen due to the complexity of our cloud platform.

In the last year, we have applied several enhancements to the cloud stack, which have improved its performance and elasticity, bringing the availability way above the SLA contractual agreements. These efforts have made our infrastructure more reliable for customer projects, enabling further business growth as we are keen to continue making further improvements.

To minimize all future risks of such issues, the following actions
have been taken or they will be worked on in the upcoming period:

  • Fix of the faulty patch, to remove future dependencies with the backup script, including reassessed and improved quality assurance and change review processes.
  • Change the way how the backup script is deployed and maintained in cloud, to avoid having future unexpected issues.
  • Review monitoring events, to lower detection and resolution time of incidents.
  • Review and improve code documentation and dependency mappings, to ensure improved clarity on the future code changes, and understand better their implications.

We apologize again for all inconveniences caused by the recent issues to your business and we want to assure you that what happened last Friday, it is not the norm at Jedox, but only an unfortunate and isolated case.

We are committed to continue our efforts to deliver the highest quality of services to our customers.

If you have any further questions or concerns, please do not hesitate to contact our Support Team via Jedox Customer Portal

Thank you for your understanding.

January 26, 2024 · 16:02 CET
Resolved

Dear customer,
The current issue that triggered the incident this morning has been solved.

We will provide communication on the root cause and remediation actions that would follow-up.

If you have any further questions or concerns, please do not hesitate to contact our Support Team via Jedox Customer Portal.

Thank you for your continued partnership and patience!

January 19, 2024 · 10:35 CET
Update

Dear customer,

This is an update on the current major incident that was opened this morning: we have deployed a patch that fixes the current issues with the login page for customers from West EU and North EU regions.
Customers from those regions should not experience any issues with login page.

We are continuing our investigation to make sure no other problems are occurring.
We will follow-up with another communication once the incident will be closed.

If you have any further questions or concerns, please do not hesitate to contact our Support Team via Jedox Customer Portal.

Thank you for your continued partnership and patience!

January 19, 2024 · 09:52 CET
Issue

Dear customers,

We are experiencing issues after the planned maintenance activities, which are impacting clients from EU cloud regions.

All affected users are expected to see “404 error” at the login page.

Our Engineers are working actively on making the necessary adjustments, to restore the availability all impacted instances as soon as possible.

A new update will be done through Status Page once restoration is applied on all affected regions.

Apologies for any inconvenience caused and Jedox remains committed to drive corrective actions to avoid future recurrences.

If you have any further questions or concerns, please do not hesitate to contact our Support Team via Jedox Customer Portal.

Thank you for your continued partnership and patience!

January 19, 2024 · 08:24 CET

← Back